
 SID Monitor Overview

SID monitor is a utility for SID monitoring stations. It has been designed to automate as much as possible the data acquisition and

storage tasks, so that the user can focus on data analysis.

SID monitor acquires digital data from a VLF receiver. Up to 16 channels can be monitored simultaneously.

Each channel signal level is periodically sampled and stored in a database. To that purpose, SID monitor embeds RRDTool data

logging and graphing application. All RRDTool low-level database management and graph generation commands are

automatically handled by SID monitor .

RRDTool also includes an aberrant behavior detection algorithm. This algorithm is used to warn the user of potential SID

detection. Warning messages can be sent by email.

Monthly snapshots of the database are done.

SID monitor also include help for generating monthly reports which format is compliant with the NGDC (National Geophysical

Data Center ) as required by the AAVSO (American Association of Variable Star Observers ) for reducing data gathered by all VLF

monitoring systems.

SID monitor automatically downloads the X-ray flux measurements from GOES-10, GOES-11 and GOES-12 satellites. As a

comparison means, those values can be plotted on the signal level graphs.
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System Requirements

SID monitor is a .NET application written in Visual C#.

It has been compiled on Visual Studio C# 2005 Express Edition .

It consists of about 50,000 lines of code.

Hardware:

Basically, any PC can be used. Nominally, in data acquisition mode, CPU requirements are very low and memory usage is about

14 Megs.

Note: Specific functions such as "Reapply New Algorithm Parameters" are very CPU and memory consuming. In this case, a 2GHz

CPU and 512Mb to 1Gb of RAM are welcome, depending of the number of channels being used.

Connection to the analog-to-digital converter (MAX187) is done through a serial (COM) port.

The software has also been tested on a USB-to-serial port converter.

Support of LPT ports and MAX186 multichannel ADC is planned in a future release.

Software:

SID monitor should run on any Windows platform running .NET 2.0. It has successfully been tested on Windows XP SP2 Home

Edition, Windows XP SP2 Professional Edition and Windows Server 2003 SP1.

The following prerequisites are required:

Microsoft .NET 2.0 Redistributable Package. You can download it here .

RRDTool. It is a data logging and graphing application. You can download it here .

Installation

SID monitor can be installed either manually by downloading binary archives, automatically through an installer or online. Online

installation is more intrusive to the system but is easier and it offers automatic updates functionality.

Manual Installation:

Install RRDTool.

Install .NET Framework 2.0.

Download SID monitor archive here . Extract it and copy it to any folder.

Automatic Installation:

Install RRDTool.

Download SID monitor installer here and execute it. .NET Framework 2.0 will automatically be installed if necessary.

Online installation Installation:

Install RRDTool.

Execute SID monitor online installation . .NET Framework 2.0 will automatically be installed if necessary.



After the installation, it is necessary to configure the application (paths to RRDTool and database folder, channels setup...).

Refer to Options menu for more information.

SID monitor uses the Windows registry only for the "Automatic start when user logs" option. The registry key that is accessed is

"HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Run". An "SID_monitor" entry is added if automatic start is

enabled.
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 Graphical User Interface

SID monitor main window consists of:

a menu bar;

a graph display area with zooming capabilities;

a date pane , a channels pane and a GOES pane , selectables through tabs;

a message area ;

a status bar .

The various panes are dockables and can be hidden to save space.

A notification icon is present in the windows system tray to indicate the application status. A menu is available by right-clicking on

this icon.

When the main window is minimized, if the "Minimize to Tray" option is set, no tab is present in the taskbar and the application can

be restored by double-clicking the notification icon or via the menu.
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Menubar

Most of the menu items are directly accessible through shortcuts.

Also, as with any Windows application, menu items are accessible by the keyboard after pressing the Alt key.

The menubar contains the following elements:

the File menu:

It is used for exiting the application (  ).

Note: one can also use the notification icon .

the View menu:

It is used for showing the various tabs.

the Data menu:

It is used for:

starting or stopping the signal level sampling.

Note: this can also be done through the status bar or the notification icon .

 resetting the history values of the aberrant behavior detection algorithm. This asks the algorithm to forget what it has

learnt so far.

Note: This may be useful after a change in the tuning parameters or if the algorithm is "diverging".



 reapplying to the existing data new parameters of the aberrant behavior detection algorithm .

Note: This may be useful if one wants to process the existing database with a new set of parameters.

This operation is very demanding in terms of memory (1Gb of RAM is welcome) and of processing time (expect a few tens

of minutes to a few hours, depending on the database size.)

the Graph menu:

It is used for:

starting or stopping the automatic update of the graph display .

Note: one can also use the status bar or the notification icon .

 asking for an immediate refresh of the graph with up-to-date values.

Note: one can also use the graph contextual menu , the date tab , the channels tab or the GOES tab .

 Save current graph as a PNG file.

Icon is grayed out if no image is displayed.

Note: one can also use the graph contextual menu .

the Reports menu:

It is used for:

 generating a report . This is normally to be done on a monthly basis.

 viewing existing report : list of events with their characteristics and the associated graphs.

 saving as an RTF file the messages logged in the message window .

Note: one can also use the message window contextual menu.

the Tools menu:



It is used for:

 accessing the sunrise and sunset times calculator .

The "Minimise To Tray" checkbox asks to minimize the application to the system tray only. If set, no SID Monitor tab if

present in the Windows taskbar when the application is minimized.

Note: one can also use the Options/Startup panel.

 setting application options .

the Help menu:

It is used for:

   accessing this help information.

 checking for application updates.

Note: this option is enabled only for an online installation. Please refer to Installation for more information.

 opening the "About..." information box .
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 Graph area

Plots are periodically generated if the graph automatic update is enable, either in the graph menu , the status bar or the

notification icon .

Plot content can be adjusted through the date tab , the channels tab and the GOES tab .

Many parameters, such as line colors and refresh period, are defined in the options menu .

Mouse graph interaction

Zoom

Zoom in and zoom out capabilities are available through the mouse wheel.

Zooming in and out is limited to a factor of about 6 times.

The zoom ratio is shown (if different from 1.0) in the bottom-right of the viewing area.

When the plot size fits entirely in the viewing area, it is not possible to zoom out any further.

Pan

If the plot size exceeds the viewing area, the cursor changes to a hand ( ). It is then possible to pan the graph in any direction by

moving the mouse with the left button pressed.

When the plot size fits entirely in the viewing area, the cursor has a cross shape ( ).

Graph contextual menu

Right-clicking in the graph area opens a contextual menu. This menu allows to:

Zoom in/out the image without modifying the image resolution:

 zoom in,

 zoom out,

 reset zoom factor to 1.0.

Icons are grayed out if a zoom factor limit is exceeded.

Change the image resolution:

 increase image size,

 decrease image size,

 revert to default size.



Image resolution can be scaled up or down by a factor of about 4.

Icons are grayed out if an image size limit is exceeded.

 Updates the graph image.

 Save current graph as a PNG file.

Icon is grayed out if no image is displayed.
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 Date Tab

This tab selects the time range of the graph displayed in the graph area .

Four options are available:

"Today": the graph is plotted for the current day from 00h00 to 24h00.

"Last 24 hours": the last 24 hours are plotted. The graph end to the current time.

"Select date": a given day, or a range of days, can be selected from the calendar. Graph will be plotted from 00h00 of the first

selected day to 24h00 of the last selected day.

"Select range": The "From" and "To" fields can be filled in to specify range of the graph plot. This is useful for zooming in on a

specific period of time for in-depth event analysis.

Missing data are indicated by red bands.

This tab allows to show an history of 1 month of measurements.

Note: All times and dates in SID Monitor are expressed in UTC. The application relies on Windows timezone setting for the UTC



time calculations.

The lower part of the tab contains the UTC time at which the graph currently displayed has been generated.

A button is available to refresh immediatly the graph.

Note: one can also use the Graph menu , the channels tab or the GOES tab .

Copyright (c) 2006 Lionel Loudet

Home Page: http://sidstation.lionelloudet.homedns.org/sidmonitor/

Support: lionel@lionelloudet.homedns.org



 Channels Tab

This tab selects the elements plotted in the graph displayed in the graph area .

The following options are available:

"Show Sun" checkbox, to indicate whether or not sunrise/sunset and twilights times are displayed. Only the period of time

between the sunrise and the sunset patterns is usable for SID events detection.

"Show Forecast" checkbox, to indicate whether or not aberrant behavior detection algorithm confidence bounds are displayed.

Detected failures (indicating a potential event, provided the algorithm is correctly tuned) are indicated by vertical bands.

"Displayed channels": the user can select which channels are displayed. Up to 16 ADC channels can be monitored. The real

time value of the signal level is also indicated. It is expressed in mV.

Missing data are indicated by red bands.

The lower part of the tab contains the UTC time at which the graph currently displayed has been generated.

A button is available to refresh immediatly the graph.



Note: one can also use the Graph menu , the date tab or the GOES tab .
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 GOES Tab

This tab selects the GOES data plotted in the graph displayed in the graph area .

GOES data are automatically downloaded from the internet. The values are provided by the Space Environment Center of the

National Oceanic & Atmospheric Administration (NOAA).

The values are stored in a specific database.

The plotted values correspond to the solar X-ray flux in the 1-8 Angstrom (0.1-0.8 nm) passband as measured by satellites GOES-

10, GOES-11 and GOES-12.

The X-ray flux is measured in W/m². The values are scaled to fit in the signal level plot.

X-class flares: above 2.5V (>10-4 W/m²). They are major events that can trigger planet-wide radio blackouts and long-lasting

radiation storms.

M-class flares: between 2V and 2.5V (10-5 to 10-4 W/m²). They can cause brief radio blackouts that affect Earth's polar



regions.

C-class flares: between 1.5V and 2V (10-6 to 10-5 W/m²). They are small with few noticeable consequences here on Earth.

B-class flares: between 1V and 1.5V (10-7 to 10-6 W/m²).

A-class flares: below 1V (<10-7 W/m²)

Flares above M1 (1·10-5 W/m²) should be detected by the monitoring station.  

The following options are available:

"Show GOES-10 X-ray flux" checkbox, to select display of data recorded by GOES-10.

"Show GOES-11 X-ray flux" checkbox, to select display of data recorded by GOES-11.

"Show GOES-12 X-ray flux" checkbox, to select display of data recorded by GOES-12.

The time of the last download of GOES data is indicated. It is possible to perform an immediate update of the information.

GOES data update occurs only if two GOES measurements out of three are available.

The lower part of the tab contains the UTC time at which the graph currently displayed has been generated.

A button is available to refresh immediatly the graph.

Note: one can also use the Graph menu , the date tab or the channels tab .
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Message Pane

The message pane logs information, warning and error messages provided by the application.

information messages are in black

warning message are in orange . Warning message indicate a non-nominal behavior that has no effect or can be recovered

without user interaction.

error messages are in red . Error messages indicate a serious problem that normally requires user interaction to be solved. For

instance, when the serial port is locked by another application.

Each message is logged with the corresponding UTC date and time.

The here above message pane example shows information message logged every 20 sec. at each database update. It contains

the name of the datasets being updated ("HO23") and the number of elements (here, normally 10 per period, meaning that the

signal level is sampled with a 2 sec. resolution).

Two warning messages have been raised for ADC response timeout, corresponding to either a connection problem with the ADC

converter or a CPU limitation (another process has consumed too much CPU and led SID monitor ADC watchdog to raise a

timeout). Consequently, the next database update contains only 8 values.

A left click on the message pane raises the contextual menu.

It allows to save all logged messages as a RTF file.

Note: one can also use the Reports menu .
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Main Window Status Bar

The Status Bar contains:

on the left-hand side, the database filename currently used by the application for storing signal level data.

on the right-hand side, two lights named "ADC" and "Graph", indicating respectively the status of the signal sampling and the

status of the graph display automatic update.

Double-clicking on a light toggles its state.

Note: one can also use the Data menu /Graph menu or the notification icon contextual menu.

Green light ( ) indicates that the ADC/graph timer is active. Yellow light ( ) indicates that the timer is stopped.

Copyright (c) 2006 Lionel Loudet

Home Page: http://sidstation.lionelloudet.homedns.org/sidmonitor/

Support: lionel@lionelloudet.homedns.org



 Notification Icon

A notification icon is present in the system tray of the windows taskbar (notification area).

A double-click on the icon hides or restores the application main window.

If the "Minimize to Tray" option is set, when SID Monitor is minimized, no tab is present in the taskbar to save space.

The notification icon is in color (  ) when the data sampling is running and in grey (  ) when the data sampling is stopped.

A right-click on the icon raises a contextual menu that allows:

starting or stopping the signal level sampling.

Note: one can also use the status bar or the Data menu .

starting or stopping the automatic update of the graph display.

Note: one can also use the status bar or the Graph menu .

 exiting the application.

Note: one can also use the File menu .

restoring the application main window.
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 Options

The options window is used to set application parameters.

 Startup for setting application startup parameters.

 Data Acquisition for setting acquisition update period.

 Channels for setting each channel characteristics.

 Database for RRDTool program and database filenames.

 Forecast for parameters linked to the RRDTool aberrant behavior detection algorithm.

 Graph for graph general parameters.

 Reports for reports and alerts settings.

 Location for defining station location.

The options are stored on a per-user basis. Initial values are provided after application installation.

At application startup, if a parameter in invalid (e.g. wrong filename), the options window is automatically displayed.

Panels containing invalid values are highlighted in red. An icon ( ) identifies which parameter is invalid and information regarding

the origin of the problem is provided.
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 Options Startup

This panel is used to set the startup options of SID Monitor .

It is possible to automatically start SID Monitor when the user logs. This can be useful to ensure that data acquisition continues

when the computer reboots for any reason.

SID Monitor can be set to initially start minimized through the "Start Minimized" option.

The "Minimize to Tray" option allows to save some space on the Windows taskbar. If selected, only the notification icon is visible in

the system tray when the application is minimized.
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 Options Data Acquisition

This panel is used to set:

The acquisition update parameter that corresponds to the sampling period of the signal level. Minimum value is 2 sec.

The period of the GOES data download, in hours between 1 and 24. Internet access is necessary to allow GOES data update.
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 Options Channels

Up to 16 channels can be monitored by SID Monitor . This panel is used to select which channels are active.

Each channel has the following parameters:

the port name used to access the ADC converter. This information is selectable from a list of ports available on the computer.

the station code of the VLF transmitter being monitored. This code consist of the final two letters of the station call sign

followed by the transmitter frequency rounded to the nearest integer. For instance, the station code of NAA on 24.0kHz is

AA24 and the station code of DHO on 23.4kHz is HO23. This code is used as a dataset name for the RRDTool database.

a short description of the channel being monitored. This is used as a legend for the graph.

the line width and color of this channel on the graph.

This panel is also used to precise the color and the titles of the GOES plots. The titles are used as legend for the GOES plots.
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 Options Database

This panel is used to set:

The location of the RRDTool program. This program is used to store data and to generate graphs.

The location of the history folder. Monthly backups of the databases are stored in the selected folder.

The filename of the database used to store the signal level measurements.

The filename of the database used to store the GOES X-ray flux data.
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 Options Forecast

This panel is used to set all the parameters of the Holt-Winters aberrant behavior detection algorithm.

More information on the effect of the various parameters is available in the Forecast FAQ .
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 Options Graph

This panel sets the periodicity of the graph update. Automatic update of the graph is enabled or disable through the Graph menu ,

the status bar or the notification icon contextual menu .

Sun Options

It is also used to choose the colors for the twilight and night bands that are displayed on the plot. They can be used to correlate

signal level sunrise and sunset patterns with actual sunrise and sunset times. The channels pane is used to enable the display of

the bands.

Forecast Options

Parameters for the display of forecast algorithm results are available in this panel.



The color of the failure marks can be choosen. These marks indicate when the algorithm has detected an aberrant behavior.

The color of the confidence bands calculated by the forecast algorithm can also be selected. The color is obtained by a lightening

of the corresponding channel line color. Each band (1 s , 2 s , 3 s ) has its own fading parameter. The effect of the color fading can

be previewed for a selectable color.

The channels pane is used to enable the display of the failure marks and of the confidence bands.

More information on the forecast algorithm can be found here .
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 Options Report and Alert

 The observer ID provided by the AAVSO must be set here so that it is correctly included in the reports generated by the

application.

 SID Monitor offers the possibility to send daily or hourly mail alerts when an SID event has been detected by the aberrant

behavior detection algorithm. Optionnaly, the graph can be attached to the mail.

It is necessary to precise:

The mail sender address in the "From" field.

The mail receiver address in the "To" field.

The SMTP server to use for mail transfer (either fully-qualified server name or IP address)

The SMTP server port. Default is 25.
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 Options Location

This panel is used to set latitude and longitude of station location. This information is used for sunrise, sunset and twilights time

calculation. The sun position is stored in the database. SID events can only be detected during the day-time period.
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 Reapply Algorithm Parameters

The "Reapply Algorithm Parameters" toolbox allows to force re-execution of the Holt-Winters aberrant behavior detection algorithm

with a new set of parameters to the whole content of a database.

 Note that this operation is very demanding in terms of memory (1Gb of RAM is welcome) and of processing time (expect a few

tens of minutes to a few hours, depending on the database size...)

The Database to process is by default the current database. Other databases can be selected by entering their neame in the

"Database" field or by the "Select..." button.

The new set of parameters can then be selected by the sliders. More information on the effect of the various parameters is

available in the Forecast FAQ .

When all parameters are set, press the "Ok" button to start the processing. The operation can be cancelled any time.

A copy of the initial database will be created with the extension .old.rrd .
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 Generate Report

The report must follow a format prescribed by the NGDC and the AAVSO .

Note that one report must be generated for each station code. Take care to follow the naming conventions.

Here is an example of report file:

   AAVSO Sudden Ionospheric Disturbance Report

Observer: A---

Station: HO23

Database: sid.0406.rrd

GOES Database: goes.0406.rrd

Date: 04/06

40   060405  1306 1430U1409                 2+    5HO23              A---

40   060405  1518 1650U1521                 3     5HO23              A---

-- end report --

SID Monitor provides help in reducing the data and generating a correct report format.

The Generate Report toolbox is opened through the Reports/Generate Report menu.



Report Selection

The user has the possibility to:

generate a report for a given date, by filling in "Month" and "Year" fields. This is the most straightforward means to use that

toolbox.

update an existing report.

select a specific database.

When a date is being selected, the database and GOES filenames are searched in the current folder is the report is for the current

month, or in the history folder that corresponds to the selected month.

When a database file is choosen, the program determines the date and searches for an associated GOES database file.

The corresponding graph can then be displayed in the graph area.

It is possible to select a the graph day and the channels to display. The options "Show Sun", "Show Forecast", "Show GOES10",

"Show GOES11" and "Show GOES12" are available and have the same affect as in the main window graph area.The graph area

offers the same functionalities (zoom and pan) as the main window graph area.

When an existing report file is selected, the events contained in the report file are displayed in the Events table.

If the associated channels and GOES database are present in the same directory as the selected report, they are indicated in the

"Channels database" and "GOES database" fields.



The databases are searched in the following locations:

first from the "Database:" and the "GOES Database" fields of the header of the report file;

then from the filenames sid.MMYY.rrd and goes.MMYY.rrd , where MM and YY are respectively the month and the year of the

report;

finally from the filenames sid.rrd and goes.rrd .

The Output pane displays specific messages indicating the status of the operations.  

Events Modification

A contextual menu allows to add, edit or delete events from the table. The same operations can be done through the "File/Edit"

Menu .

Selecting "Add Event" ( ) opens a windows to fill in the SID event information. More information on the format of the report file

and on the definition on the fields is available in the Reports FAQ .

Selecting "Edit Event" ( ) opens a windows to fill in the SID event information.

Selecting "Delete Event" ( ) deletes the events currently selected in the table.

Menubar

The menubar contains the following elements:

the File menu:

It is used for:

 loading a database file.

Note: one can also use the "Select..." button from the Report pane.

 loading a report file.

Note: one can also use the "Select..." button from the Report pane.

 saving report files.

saving empty report files.

Note: this allows to create empty report files for station code that do not have events to save.

 closing the "Generate Report" toolbox.



the View menu:

It is used for showing the various tabs.

the Edit menu:

It is used for adding ( ), editing ( ) and deleting ( ) SID events from the Events pane.

Note: one can also use the contextual menu of the Events pane.

the Help menu:

It is used for accessing this help information (   ).
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 View Report

The View Report toolbox is opened through the "Reports/View Existing Report" menu.

Report Selection

The report file selected in the "Report filename" field is processed. By default, report file extension is expected to be .dat .

The events listed contained in the report file are displayed in the Events table.

More information on the format of the report file and on the definition on the fields is available in the Reports FAQ .

If the associated channels and GOES database are present in the same directory as the selected report, they are indicated in the

"Channels database" and "GOES database" fields.

The databases are searched in the following locations:

first from the "Database:" and the "GOES Database" fields of the header of the report file;

then from the filenames sid.MMYY.rrd and goes.MMYY.rrd , where MM and YY are respectively the month and the year of the



report;

finally from the filenames sid.rrd and goes.rrd .

If those filenames are found, the graph area is used to display the graph of the day that corresponds to an event selected from the

table.

Options "Show Sun", "Show Forecast", "Show GOES10", "Show GOES11" and "Show GOES12" are available and have the same

affect as in the main window graph area.

The graph area offers the same functionalities (zoom and pan) as the main window graph area.

The Output pane displays specific messages indicating the status of the operations.  

Menubar

The menubar contains the following elements:

the File menu:

It is used for:

 loading a report file.

Note: one can also use the "Select..." button from the Report pane.

 closing the "View Report" toolbox.

the View menu:

It is used for showing the various tabs.

the Help menu:

It is used for accessing this help information (   ).
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 Sunrise and Sunset times calculator

This utility indicates for a given day the sunrise, sunset and twilight times.

The civil twilight correspond to a sun position between 0 and -6° below the horizon.

The nautical twilight correspond to a sun position between -6° and -12° below the horizon.

The astronomical twilight correspond to a sun position between -12° and -18° below the horizon.

The noon time correspond to the highest sun altitude.

Calculations are done for the location provided in the options / location panel .

The sunrise and sunset times are precise to a few minutes which is sufficient for our purpose.
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 About information box

This box indicates program version, author's contact and web site link , as well as licence information.
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 FAQ

What are the rules for filling in correctly the monthly report?1.

How are defined the RRDTool databases?2.

What's the meaning of all of those "Forecast parameters"?3.
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 FAQ – Reports

The following elements are required when filling in the report. This section includes excerpts from the AAVSO requirements for

defining those parameters. For more information, refer to the AAVSO SID Program website.

Here is an example of SID event correlated to the GOES measurements:

The red and violet lines correspond to GOES-10 and GOES-12 measurements of the x-ray flux.

The green line correspond to the signal level measurement with the confidence bands of the forecast algorithm.

Event Start : The moment when an event begins. Be aware that the amplitude of different events varies considerably, and some

may appear in inverted form. If it is obvious that an event began before the first definable start time, an 'E' (before) is appended to

the recorded time.



Event End : Of the three times, the end time is the most difficult to determine. It is defined as the moment when the trace returns

to the diurnal trend line, or is interrupted by the onset of a new event. In the latter situation, the letter 'D' (after) is appended to that

time, which in turn becomes the start time for the following event.

Event Maximum : The moment when the ascending (descending in the case of inverted events) branch slows its sharp rise. Note

that this generally does not coincide with the event's peak amplitude.

If the trace goes off-scale as maximum is approached, or is interfered with in some other manner such as the onset of sunset,

device failure, etc., we append a 'U' (uncertain) to the last identifiable time. For example, if the SID maximum occurs somewhere

off-scale and the last determinable time is fourteen hours, ten minutes (1410), the time is recorded as 141OU.

Importance generally refers to the length of an event, found by subtracting the start time from the end time. The table at right

associates the Importance rating with event duration.

With respect to the observer's typical daily trace, a class 1 SID is an event with small intensity change and a relatively short

duration. Class 2 is a moderate intensity event with a fairly long duration, and a class 3 describes a SID with a 'great' change in

intensity and long duration.

< 19 min

1-

19-25

1

26-32

1+

33-45

2

46-85

2+

86-125

3

> 125

3+

Duration Importance

Definitiveness or Definition is a subjective estimate of an observer's confidence in the event. Normally, the events which are

included in our reports have Definitions equal to 3 or greater. Use the right-hand scale as a guide to Definition. Careful study and

experience teaches observers how to recognize false SID events caused by man-made interference. Beginners should not

hesitate to assign high Definition values to those events which are not correlated with known noise sources. Other observers'

results will be compared to eliminate suspect events before a final report is submitted to the NGDC.

Questionable

0

Possible

1

Fair

2

Reasonable

3

Reasonably

Definite

4

Definite

5



Confidence Definition

Note that the filename must respect the AAVSO requirements which are recalled here:

Data files must be named according to the observer and the station monitored.

Each observer has an ID code. i.e. A87

Each observer monitors a VLF station with a 3 letter call sign. i.e. NAA

The file name should reflect these two pieces of information: A87NAA.dat
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 FAQ – Databases

SID Monitor uses RRDTool for the management of the databases. This tool handles databases according to the "round robin"

scheme. They have predefined fixed sizes, and the newer values are overwritten over the oldest ones.

This FAQ assumes the reader has a good knowledge of RRDTool commands.

Channels Database

Contents

The Channels database stores all channels signal levels. It has a capacity of 31 days. One dataset named sun is defined to store

the sun position with an update period of 1 minute.

Each channel has its own dataset. Nominal refresh period of the signal level is set in the Data Acquisition panel.

Example

Here is an example of creation of the Channels database.

   rrdtool create "D:\...\sid-test.rrd"

   --start 1147361783 --step 10

   DS:sun:GAUGE:120:0:8

   DS:test:GAUGE:20:0:4096

   RRA:AVERAGE:0.99:1:267840

   RRA:HWPREDICT:267840:0.50:0.50:8640:3

   RRA:SEASONAL:8640:0.50:2

   RRA:DEVSEASONAL:8640:0.50:2

   RRA:DEVPREDICT:267840:4

   RRA:FAILURES:267840:7:9:4 

   

Refresh period (step ) is set to 10 seconds. It corresponds to the sampling period of the signal level as defined in the Options

menu.

Two datasets are created, sun and test with a GAUGE data type.

For the sun dataset, the heartbeat is set to 120  seconds, meaning that at least one value every two minutes is necessary,

otherwise the interval value will be set to Unknown. Nominal update is every minute. Minimum and Maximum values are

respectively set to 0 and 8.

For the test dataset, the heartbeat is set to 20 seconds, meaning that at least one value out of two is necessary, otherwise the

interval value will be set to Unknown. Minimum and Maximum values are set to 0 and 4096, expressed in mV.

The first archive stores actual values from the 'sun' and the 'test' datasets. It has the AVERAGE consolidation function, with a step

parameter of 1, meaning that no average is done. The number of rows (267840) corresponds to the number of 10-seconds

intervals in 31 days... The xff parameter is set to 0.99, meaning that 99% of the data may be missing while still validating a given

interval.

The subsequent archives HWPREDICT , SEASONAL , DEVSEASONAL , DEVPREDICT and FAILURES are related to the Holt-Winters

algorithm. "Alpha", "Beta", "Gamma seasonal" and "Gamma dev seasonal" parameters are set to 0.5. The seasonal period (8640)

corresponds to the number of 10-seconds intervals in one day. The window length (9) and the threshold (7) have their default

values.

GOES Database

Contents

The GOES database stores all GOES X-ray flux values downloaded from the internet. It has a capacity of 31 days.



It contains three datasets, goes10 , goes11 and goes12 , corresponding to each source of data. Nominal refresh interval is

1 minute.

Example

Here is an example of creation of the GOES database.

Refresh period (step ) is set to 60 seconds. It corresponds to the sampling interval of the X-ray flux data.

Three datasets are created, goes10 , goes11 and goes12 with a GAUGE data type. Heartbeat is set to 120 seconds, meaning that at

least one value every two minutes is necessary, otherwise the interval value will be set to Unknown. Minimum and Maximum

values are not set.

Only one archive is defined. It has the AVERAGE consolidation function, with a step parameter of 1, meaning that no average is

done. The number of rows (44640) corresponds to the number of minutes in 31 days... The xff parameter is set to 0.99, meaning

that 99% of the data may be missing while still validating a given interval.

   rrdtool create "D:\...\goes-test.rrd"

   --start 1144683393 --step 60

   DS:goes10:GAUGE:120:U:U DS:goes11:GAUGE:120:U:U DS:goes12:GAUGE:120:U:U

   RRA:AVERAGE:0.99:1:44640
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 FAQ – Forecast

RRDtool includes:

the Holt-Winters forecasting algorithm that is used to adaptely predict future values;1.

a measure of the deviation between predicted and observed values, and definition of confidence bands;2.

aberrant behavior detection mechanism that flags observations that are too deviant from the predicted values.3.

Forecasting

The prediction is based on the Holt-Winters forecasting algorithm. It adaptively predicts future observations in a time series.

This forecast is the sum of three components:

a baseline (or intercept),

a linear trend over time (or slope),

a seasonal coefficient (a periodic effect, such as a daily cycle in our case).

There is one seasonal coefficient for each time point in the period (cycle). After a value is observed, each of these components is

updated via exponential smoothing. This means that the algorithm "learns" from past values and uses them to predict the future.

The rate of adaptation is governed by 3 parameters:

alpha : a is the adaption parameter of the intercept (or baseline) coefficient in the Holt-Winters forecasting algorithm. a must lie

between 0 and 1. A value closer to 1 means that more recent observations carry greater weight in predicting the baseline

component of the forecast. A value closer to 0 means that past history carries greater weight in predicting the baseline

component.

beta : ß is the adaption parameter of the slope (or linear trend) coefficient in the Holt-Winters forecasting algorithm. ß must lie

between 0 and 1 and plays the same role as a with respect to the predicted linear trend.

gamma seasonal :   is the adaption parameter of the seasonal coefficients in the Holt-Winters forecasting algorithm. It must

lie between 0 and 1. Note that because there is one seasonal coefficient for each time point during the seasonal cycle, the

adaptation rate is much slower than the baseline. Each seasonal coefficient is only updated (or adapts) when the observed

value occurs at the offset in the seasonal cycle corresponding to that coefficient.

The closer the parameters are from 1, the faster the algorithm adapts.

Confidence Bands

The measure of deviation is a seasonal weighted absolute deviation. The term "seasonal" means deviation is measured separately

for each time point in the seasonal cycle. As with Holt-Winters forecasting, deviation is predicted using the measure computed

from past values (but only at that point in the seasonal cycle). After the value is observed, the algorithm learns from the observed

value via exponential smoothing. Confidence bands for the observed time series are generated by scaling the sequence of

predicted deviation values.



gamma seasonal deviation is the adaption parameter in the exponential smoothing update of the seasonal deviations. It must lie

between 0 and 1. The closer it is from 1, the faster the algorithm adapts. Note that because there is one seasonal deviation for

each time point during the seasonal cycle, the adaptation rate is much slower than the baseline.

Aberrant-behavior detection

Aberrant-behavior (a potential SID event) is reported whenever the number of violations (observations that fall outside the

confidence bands) exceeds a specified threshold within a specified moving temporal window.

The following parameters affect the detection mechanism:

upper bound or deltapos : d + alters the deviation scaling factor for the upper bound of the confidence band used internally to

detect a violations. The default value is 2.

lower bound or deltaneg : d– alters the deviation scaling factor for the lower bound of the confidence band used internally to

detect a violations. The default value is 2.

threshold is the minimum number of violations (observed values outside the confidence bounds) within a window that

constitutes a failure. The default value is 7.

window length is the number of time points in the window. Specify an integer greater than or equal to the threshold and less

than or equal to 28. The time interval this window represents depends on the acquisition update time. The default value is 9.

Note: This information is based on RRDTool documentation and on the paper "Aberrant Behavior Detection in Time Series for

Network Monitoring" by Jake D. Brutlag, Proceedings of the 14th Systems Administration Conference (LISA 2000), New Orleans,

Louisiana, USA, December 3-8, 2000.
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SID monitor source is freely available on the author website.

Nothing made by a human can reach perfection. This software has necessarily shortcomings and bugs. The author welcomes any

feedback, comment or suggestion on SID Monitor , provided they help improving it.

Licence

Copyright (C) 2006 - Lionel Loudet.

This program is free software; you can redistribute it and/or modify it under the terms of the GNU General Public License as

published by the Free Software Foundation, at version 2 of the License.

This program is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of

MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public Licence for more details.

You should have received a copy of the GNU General Public License along with this program; if not, write to the Free Software

Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, USA.
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 Credits

The author wants first to thanks his family members for accepting him not fully available for them for the last months. Writing and

testing about 50,000 lines is very time consuming.

Sunrise and Sunset time calculations are based on a algorithm adapted from Jarmo Lammi and Paul Schlyter .

The User Interface uses the Dock Panel Suite written by Weifen Luo.

Also, the Label with Divider written by Julijan Sribar has been useful.
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